Find answers, ask questions, and connect with our
community around the world.

Source-Connect Certification Courses Forums Source-Connect Now Allow screen WON'T go away!!!

  • Allow screen WON'T go away!!!

  • snk1296

    Member
    February 23, 2021 at 7:08 am

    Allow screen WON'T go away!!!

  • snk1296

    Member
    February 23, 2021 at 7:08 am

    Hi, guys!

    Can anyone help me? My SC-NOW refuses to let me do anything in terms of hosting or joining guest sessions because it keeps taking me to this Click on the Allow button page. I've been through with phone support, we tried EVERYTHING and it's still doing it. I have Standard, but most clients ask for SC-NOW today and in the future. Please help!!!

  • snk1296

    Member
    February 23, 2021 at 7:21 am

    For reference, I am using an Universal Audio Apollo Solo USB-C as my input device, Windows 10 Home 64-bit is my operating system, and NVIDIA Virtual Audio Device is my sound card I believe but I typically go straight through my interface's ASIO.

  • romano_cwb

    Member
    February 25, 2021 at 12:31 pm

    Hi!
    I have the same issue. May be someone could help us…

  • P Cowlinator P Cowlinator

    Member
    April 23, 2021 at 6:31 am

    I had this issue also. The error screen says “you must click the ‘allow’ button where it asks you, at the top right of this Chrome browser window” so that Chrome has permission to use the microphone on now.source-elemets.com .

    So, first of all, Chrome generally places that in the top left now. But that’s not so important.

    The real problem is that this error message is false. The “allow/deny” dialog wasn’t showing up for me because Chrome already has permission. I triple checked this. The site is failing to detect my mic, and instead of saying “we can’t find your mic”, it gives this false error message.

    I was using an expensive XLR microphone when I encountered this problem. Then, I plugged in a crappy USB mic, and it worked. I was able to connect to my colleagues. Then, when I changed the “Audio Input” setting to my nice mic and hit “refresh with new settings”, it brought me back to the “you must click the ‘allow’ button” screen again. I had to plug the crappy mic back in and clear my Chrome cache and cookies before it would work again.

    Summary: Source connect doesn’t seem to support anything except USB microphones. When a microphone is not supported, the error message is complete misinformation.

  • jongordon

    Member
    June 25, 2021 at 12:22 am

    So do I understand correctly that Source Connect Now simply does not work if it cannot detect a microphone attached to the host computer? But a USB mic could do the trick?

    Sorry if it’s a dumb question…

    JG

  • James Regan James Regan

    Member
    October 21, 2021 at 3:45 pm

    I One of the talents I work with is having this same problem, she’s using a Windows machine. Is this problem unique to Windows?

Viewing 1 - 7 of 7 replies

Original Post
0 of 0 posts June 2018
Now