Find answers, ask questions, and connect with our
community around the world.

Source-Connect Certification Courses Forums Networks and configuration NAT Port mapping issues and multiple sub accounts not visible

  • NAT Port mapping issues and multiple sub accounts not visible

  • smoke

    Member
    May 10, 2019 at 6:12 am

    NAT Port mapping issues and multiple sub accounts not visible

  • smoke

    Member
    May 10, 2019 at 6:12 am

    Hello,

    We have 3 source connect sub accounts(acc*A, acc*B, acc*C) and three source connect instances running on three separate hosts(hostA, hostB, hostC) on a private network. All nodes are NATed through a single IP(extIP) and we are NATing back port pairs to each source connect host. To clarify a bit more:
    – port pair 6000,6001 gets NATed to hostA's port 6000,6001
    – port pair 6002,6003 gets NATed to hostB's port 6000,6001
    – port pair 6004,6005 gets NATed to hostC's port 6000,6001

    To my understanding each source connect instance needs to be configured with the port pairs being NATed(for example 6004, 6005 host hostC) on the listening menu and with a subaccount in order to associate the subaccount(for example acc*C) with the single external IP and the NATed port.

    We cannot find enough information on the documentation about these topics and we end up having the following issues:
    – We cannot discover(although we have enabled) the subaccounts in order to import them and try to connect from one source connect instance to another, which would greatly have simplified testing in our case
    – When we perform a port test we get port not mapped

    Any idea what is wrong on this setup ? Any pointers to further documentation would be highly appreciated

  • Jace

    Member
    May 10, 2019 at 10:17 am

    It sounds like you are on the right track to having this setup correctly. Regarding the port not mapped issue, first be sure you are specifying the correct base port under the settings in Source-Connect. For example, hostA should be 6000, hostB should be 6002, hostC should be 6004, etc. If they are still returning port not mapped, this is going to indicate an issue with the configuration. In short, you will need to allow all incoming connections over 2 sequential UDP ports for each instance. Please review the network setup guide here: https://source-elements.com/support/networkguide

    With multi-connect accounts enabled, any of your accounts should be able to see each other if they are logged in. For your contacts, they only need to add your base account and then they will be able to see that as well as any multi-accounts if they are logged in. If your multi-connect accounts are not showing up in your contacts list, I suggest disabling all of them and then re-enabling them at https://phoenix.source-elements.com/dashboard/apps/source-connect/multi/ (be sure to log out of all of the accounts before doing this)

  • smoke

    Member
    May 10, 2019 at 4:22 pm

    On the first issue it seems that we managed to overcome the "port not mapped" issue by providing a one to one port mapping. I assumed that the port number was just the payload reported to sourceconnect's server for the profile/ip/port association but it also seems that it also binds the source connect socket to the specified port.

    For the 2nd bit I'll try it on Monday and report the result(thanks for the logout hint, I would have missed that).

  • smoke

    Member
    May 13, 2019 at 4:15 am

    So as it seems source connect cannot connect from one sub account to another. Tested it though with a different account and everything seems to work as expected. Thank you for all help

  • davocal1

    Member
    August 17, 2019 at 5:14 am

    jace
    Hi Jace. davocal1 here.
    Seems like every time we get an Xfinity hiccup around here, my ports unmap? Would it be crazy for you guys to do "general set-up" video on how to remap so ports read 'open?' Ya know…like a "port mapping for dummies" video!?
    Thanks, davocal1

  • Robert

    Administrator
    August 17, 2019 at 8:25 am

    every router is different and has a different specific GUI layout to navigate to forward ports. Thus it’s not possible to make a one size fits all video.

    That said portforward.con has guides for most every router on the market and most every application including Source-Connect. If you use their guide then keep in mind that SC Standard only needs UDP ports 6000-6001 to be forwarded. Source-Connect Pro defaults to 6000 and 6001 but can use any even/consecutive odd pair above 6000. SC doesn’t require TCP ports to be forwarded.

    https://portforward.com/router.htm

    Free guides for port forwarding for any router and most every application on the market can be found there.

Viewing 1 - 7 of 7 replies

Original Post
0 of 0 posts June 2018
Now